My window to the world

Windows Vista: couple of bugs

By Mauricio Freitas, in , posted: 16-Dec-2006 12:44

It's Saturday morning here and I have just finished reinstalling Microsoft Windows Vista RTM on my desktop.

No, nothing wrong with Windows Vista before. I have never activated my previous installation and it would be running out this weekend, so I had to do it. I didn't activate Windows Vista before because I found lots of memory conflicts while running Windows Vista on my desktop, which were solved when I upgraded the machine's BIOS to the latest version, but I thought it would be better to have a fresh install after the BIOS upgrade.

I was delaying this reinstall because I am waiting for a new laptop to arrive from Microsoft, an Acer Ferrari 5000, ready to use and review with pre-installed Windows Vista. Alas, the laptop won't turn up here until a week from now, so I had to go through reinstalling everything.


I am glad I did because now Microsoft Hardware has some new drivers for Intellimouse and Intellipoint, as well as for its Fingerprint Reader. Realtek has also final drives for its HD Audio hardware, and NVIDIA has drivers for the Windows Vista RTM build. I am still waiting for imation to release an updated version of their software for the Disc Stakka though (in the meantime I am using it on my tablet PC).

There are only two things that weren't solved with this fresh install:

- Internet Explorer won't accept the trusted root certificate used on my internal server (Exchange, Newsgator), saying it's been revoked. No it hasn't, and it works fine on Firefox 2.0 and Internet Explorer 7.0 for Windows XP;

- The built-in SD card reader, which worked as ReadyBoost on Windows Vista RC2 100% of the time, and worked as ReadyBoost on Windows Vista RTM for a while, stopped working. After the reinstall it was recognised as a ReadyBoost device for a while, and again it stopped working. Why, oh why?

I can't log these as bugs anymore because the Windows Vista beta program is finished. The suggestion is to record any problems with standard Microsoft support. I will post here instead. Let's see if they read.



Other related posts:
Windows 8 Mail app not hyperlinking emails
Are we seeing the death of Windows RT?
Windows 8 Consumer Preview






comments powered by Disqus

freitasm's profile

Mauricio Freitas
Wellington
New Zealand


I live in New Zealand and my interests include mobile devices, good books, movies and food of course! 

I'm the Geekzone admin. On Geekzone we publish news, reviews and articles on technology topics. The site also has some busy forums. Also worth visiting is TravelTalk NZ, a community for travelers!

Subscribe now to my blog RSS feed or the Geekzone RSS feed.

If you want to contact me, please use this page or email me freitasm@geekzone.co.nz. Note this email is not for technical support. I don't give technical support. You can use our Geekzone Forums for community discussions on technical issues.

Here's is my full disclosure post.

A couple of blog posts you should read:


Social networks presence

View Mauricio Freitas's profile on LinkedIn


My Blog by tags...

Blog...
Entrepreneurship...
Media...
Personal...
State of Browsers...
Technology...
Viral Marketing...
Web Performance Optimization...
Windows...
Windows Phone...

Other recent posts in my blog

Google crawling Geekzone HTTPS...
Geekzone gone full HTTPS...
Microsoft Ignite New Zealand, ...
If the headlines indicate the ...
Geekzone data analytics with P...
State of browsers Geekzone Mar...
2Cheap Cars discussion...
Now with more fibre...
Unlimited is not unlimited: Vo...
How bad is Vodafone cable at t...

New posts on Geekzone