My window to the world

When Direct Push does not push

By Mauricio Freitas, in , posted: 21-Dec-2006 08:32

Interesting... Telecom New Zealand must have turned something off or changed some parameter on their network (perhaps because of the CDMA EV-DO Rev A release)?

Anyway, I run a Microsoft Exchange Server and have Direct Push enabled for a series of devices here (my own Pocket PC Phone Edition, plus a few test ones). And it's not working on CDMA devices connected to Telecom New Zealand anymore!

Until recently all devices I have connected to a cellular network would get my e-mails even before Microsoft Outlook on my desktop notified me of a new message.

This was consistently working with devices connected to Vodafone New Zealand (i-mate Jasjar, Palm Treo 750v, and another test device) or Telecom New Zealand (Apache).

But this has now changed and I noticed this when testing the Palm Treo 700wx Telecom New Zealand sent: for some reason the devices connected to their CDMA EVDO network are not getting the push e-mails.

To test it I put a series of devices side-by-side and sent a few e-mails from gmail and other on-line services to my own account on the Exchange Server. And guess what? All UMTS devices received the e-mail almost instantly, while the CDMA devices sat there, doing nothing and eventually receiving the e-mails - up to 15 minutes later.

This feature used to work for sure, and I think something has changed on the Telecom network. 

What I've noticed is that those arrows indicating a data connection go grey on the CDMA devices and while in that state they won't receive e-mails - perhaps because in this state their connection to the Exchange Server cannot be used to transfer information?

Another piece of information, it appears that it works fine if using the Telecom private office offering (I can't remember the service name),

Anyway, I contacted someone at Telecom but I was told "nothing has changed" and he would look into this in 2007.

I will keep asking about it...







Other related posts:
Windows Phone and Android apps screen comparison
Windows Phone 8 Portico update: at last here in New Zealand
Windows Phone updates, again






comments powered by Disqus

freitasm's profile

Mauricio Freitas
Wellington
New Zealand


I live in New Zealand and my interests include mobile devices, good books, movies and food of course! 

I'm the Geekzone admin. On Geekzone we publish news, reviews and articles on technology topics. The site also has some busy forums. Also worth visiting is TravelTalk NZ, a community for travelers!

Subscribe now to my blog RSS feed or the Geekzone RSS feed.

If you want to contact me, please use this page or email me freitasm@geekzone.co.nz. Note this email is not for technical support. I don't give technical support. You can use our Geekzone Forums for community discussions on technical issues.

Here's is my full disclosure post.

A couple of blog posts you should read:


Social networks presence

View Mauricio Freitas's profile on LinkedIn


My Blog by tags...

Blog...
Entrepreneurship...
Media...
Personal...
State of Browsers...
Technology...
Viral Marketing...
Web Performance Optimization...
Windows...
Windows Phone...

Other recent posts in my blog

Google crawling Geekzone HTTPS...
Geekzone gone full HTTPS...
Microsoft Ignite New Zealand, ...
If the headlines indicate the ...
Geekzone data analytics with P...
State of browsers Geekzone Mar...
2Cheap Cars discussion...
Now with more fibre...
Unlimited is not unlimited: Vo...
How bad is Vodafone cable at t...

New posts on Geekzone